Browsing this Thread:   1 Anonymous Users






Re: Problem with Photo Upload for Standart User ( not Premium )
#3
Quite a regular
Quite a regular


See User information
hi john, thanks for the fix, it works now

you can fix the orginal download file in this forum.

iI have a suggestion, you could add a option, where you can choose the usern at premium, the Classified is immediately activated?

for example admin setting:

Premium users activate Classified immediately: = Yes / No

That would be a great option

Thanks

greet host2

Posted on: 2010/3/25 2:26
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: Problem with Photo Upload for Standart User ( not Premium )
#2
Webmaster
Webmaster


See User information
I don't know what happened there, but I just added the fix to the download. Or you can do this.

Go to view_photos.php around lines 151 -156 and find these lines:

if (!empty($xoopsUser)){
if ($isOwner && $xoopsModuleConfig["".$mydirname."_nb_pict"]>$pictures_number){
$maxfilebytes = $xoopsModuleConfig["".$mydirname."_maxfilesize"];
$album_factory->renderFormSubmit($uid,$lid,$maxfilebytes,$xoopsTpl);
}
}



Change them to this:


if (!empty($xoopsUser)){

if ($permit == "1") {
if ($isOwner && $xoopsModuleConfig["".$mydirname."_nb_pict"]>$pictures_number){
$maxfilebytes = $xoopsModuleConfig["".$mydirname."_maxfilesize"];
$album_factory->renderFormSubmit($uid,$lid,$maxfilebytes,$xoopsTpl);
}
} else {
if ($isOwner && $xoopsModuleConfig["".$mydirname."_not_premium"]>$pictures_number){
$maxfilebytes = $xoopsModuleConfig["".$mydirname."_maxfilesize"];
$album_factory->renderFormSubmit($uid,$lid,$maxfilebytes,$xoopsTpl);
}
}
}




Let me know if that works for you.

Like I said I just changed the download.


John



Posted on: 2010/3/24 22:57
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Problem with Photo Upload for Standart User ( not Premium )
#1
Quite a regular
Quite a regular


See User information
Hello,

I Have a Problem with classfifieds.

in the settings I have set a standard, the member may only upload one picture, but he can upload as many as he wants. Why is that?

The problem is here in the forum (see link)

http://www.jlmzone.com/modules/classifieds/viewad.php?lid=19

i upload two picture, but actually I can only upload one ?

thanks for help.

greet host2

Posted on: 2010/3/24 17:53
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top







You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.
You cannot create pdf.
You cannot get print page.

[Advanced Search]


Login
Username:

Password:

Remember me



Lost Password?

Register now!
 
Main Menu
 
Who's Online
4 user(s) are online (3 user(s) are browsing Forum)

Members: 0
Guests: 4

more...
 
Donat-O-Meter
Make donations with PayPal!
Stats
Goal: $25.00
Due Date: Jun 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $25.00