Browsing this Thread:   1 Anonymous Users




(1) 2 »


Re: 2.0 BETA2 Preferences thro server error
#16
Zoner
Zoner


See User information
FTP:
When I first started building sites I found transferring lots of files unreliable and when things didn't work it was tricky to sort out. My solution was to transfer an archive and unpack on the host which seemed to work better.

However during my next testing session I'll try transferring the unpacked files from your archive and tell you what happens.

Posted on: 2009/11/24 7:43
GFD
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#15
Webmaster
Webmaster


See User information
GreenFlatDog,

I would have never figured that out. Also I have never used cpanel to unpack anything, although it would be quicker. And I don't use Windows.

I just added a fix to the resume section, detailed in another post, so do not use an old copy of the Jobs module, or you could fix it yourself, the fix is in the other post.

You are the only one who reported this error, I'm just glad you figured it out.

As for the Classifieds Module I have a new version that breaks up the index.php page. I do not have a url rewrite for existing sites to rewrite the old url to the new url, which would be needed for an old site using the Classifieds Module. But I should release it anyway for people starting new sites. I will try to release it by the end of the weekend, maybe before the weekend.

Thanks for keeping me informed, and again glad you figured it out.

I am curious if you tried to upload the module through ftp instead of cpanel?

Thanks,

John

Posted on: 2009/11/24 7:23
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#14
Zoner
Zoner


See User information
Hi John,
You may remember I had unexplained 'server errors' dogging me with Classifieds (and all your other modules) earlier in the year. They only occurred at my host, working locally was fine. However I couldn't track down the problem before going live and so was forced to use catads instead.

With the prospect of upgrading to xoops 2.4.0 I've had another go at installing Classifieds but with the same 'server errors' defeating me. However I have some news to report although this time with Jobs 4.0 which had the same problem before.

What I noticed was that if I uploaded the module, unpacked it using the host's cpanel file manager, moved it into the modules folder and then added a simple 'hello world' file in the jobs folder, it would fail when I browsed directly to it. But the same file would be OK if I moved it to another folder.

If I renamed the 'jobs' folder and created a new one the 'hello world' file would work. This pointed the finger at the folder from the uploaded package.

So what I have done is to unpack the module locally. Create a duplicate empty folder structure and copy the files across. Then I opened every file, checked its encoding and converted (using Notepad++) any UNIX/ANSI files to dos/windows/ANSI. Then repacked the module with winzip, uploaded this to the host, unpacked it and dropped the module into the modules folder and everything seems to work OK.

I've got no idea why my host would not run packages from your archives, particularly as nobody else has reported any issue but as far as I'm concerned I'm back with you and looking forward to using Jobs in the upgrade to xoops 2.4.0

Thanks for some great modules.

Posted on: 2009/11/23 12:55
GFD
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#13
Zoner
Zoner


See User information
No worries - hope things improve for you.

To keep things ticking along I've had to launch my site with Catads :(

But I have also been trying to alter my local development site so it better simulates my host by moving my local site from IIS to Wamp and changing the versions of mySQL and php to match the host. So far I haven't reproduced the problem so the next tasks will involve trying to switch the local site to work on php using the cgi method and possibly then going through the php.ini file line by line until everything is identical.

If you have any suggestions of other things I should look out for I'm all ears. Do the .htaccess files play a role? These seem to be zero sized (empty) files at my host.

If I can get Classifieds running I will switch over with much relief. I feel the alternative will give me a lot of grief with the users.

All the best.

Posted on: 2009/2/10 11:09
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#12
Webmaster
Webmaster


See User information
I have not been able to recreate this problem, over the last 2 months or so I have not been able to work on my modules due to personal reasons, hopefully I will get back into it in a couple of weeks.

Sorry,

John

Posted on: 2009/2/8 9:14
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#11
Zoner
Zoner


See User information
Were you able to look at this issue (server info sent via contact form mid December)?

Any pointers gratefully received.
Best regards

Posted on: 2009/1/19 8:43
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#10
Webmaster
Webmaster


See User information
I am sorry I have not been able to work on that, my mind is not right for working on my modules, lots of stress from non-computer things.

But it is strange that no one else has reported this, lots of lookers for this thread but no one saying 'I am having this same problem'.

That is why I asked about the file permissions, did you also check the folder permissions, they should be chmod 755.

If your folders are 755 or you changed them to 755 and you still have the same problem, email me with all of your server info, in Xoops admin where you show me your server specs, under there it says 'Loaded php extensions' send me that in an email, don't post that here. I will try to recreate your problem, I have not been able to so far.

Thanks,

John

Posted on: 2008/12/8 19:25
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences thro server error
#9
Zoner
Zoner


See User information
John,
Have you any thoughts on the issues my installation of Classifieds is experiencing?

Is there further information I can report to help?
Regards,

Posted on: 2008/12/8 12:31
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences throws server error
#8
Zoner
Zoner


See User information
Can't see any MySQL errors because the page that is returned is the 'Internal Server Error' page. I guess admin/index.php is not being processed at all, so no opportunity for debug to analyse anything. Is there another way the get debug info apart from the Xoops debug setting?

On checking around the topic of 'Premature end of script headers' I get the impression the server (Apache 1.3.41 with the cgi API) is trying to deal with a file that has broken, incomplete or badly formed header lines. Apparently this can be due to any number of reasons (not very helpful!) including an encoding mismatch and I read that Xoops was moving everything to UTF-8, would that be significant?

I've gone through the download, send-to-host, unpack, install module routine twice in case a file got messed up but I get the same failure, which is also the same as with the BETA packages, so I'm thinking it unlikely I'm messing up a file.

The puzzle is that the module works locally but not on my hosted server, and no other module shows this, or other problems, on the server.

Further info ...

On the same server that gives the 'Internal Server Error' when going for any admin page of Classifieds' 2.0 RC1 from the system/modules page (e.g. 'Administration', 'Categories', etc) I get the following other results:

Jobs 4.0 BETA1 >> same as Classifieds
eXTgallery 1.0.4 >> no problem
eXTcal 2.2.2 >> no problem
news 1.62 >> no problem

Also no problem with the standard modules (private messaging or user profile).

Does this narrow the issue down a bit?

Is there any other info I can give you that might help here?

Regards,

Posted on: 2008/11/30 11:51

Edited by GreenFlatDog on 2008/11/30 12:32:25
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top


Re: 2.0 BETA2 Preferences throws server error
#7
Webmaster
Webmaster


See User information
Are you getting any mysql errors with php debug on?

John

Posted on: 2008/11/30 10:32
Twitter Facebook Google Plus Linkedin Del.icio.us Digg Reddit Mr. Wong Top




(1) 2 »



You can view topic.
You cannot start a new topic.
You cannot reply to posts.
You cannot edit your posts.
You cannot delete your posts.
You cannot add new polls.
You cannot vote in polls.
You cannot attach files to posts.
You cannot post without approval.
You cannot use topic type.
You cannot use HTML syntax.
You cannot use signature.
You cannot create pdf.
You cannot get print page.

[Advanced Search]


Login
Username:

Password:

Remember me



Lost Password?

Register now!
 
Main Menu
 
Who's Online
4 user(s) are online (3 user(s) are browsing Forum)

Members: 0
Guests: 4

more...
 
Donat-O-Meter
Make donations with PayPal!
Stats
Goal: $25.00
Due Date: Sep 30
Gross Amount: $0.00
Net Balance: $0.00
Left to go: $25.00